#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[a-zA-Z0-9]+[._]?[a-zA-Z0-9]+)+$"
Local $sString = "username" & @CRLF & _
"user_name" & @CRLF & _
"user.name" & @CRLF & _
"user.name_123" & @CRLF & _
"username$$$" & @CRLF & _
"_username" & @CRLF & _
"username_" & @CRLF & _
"user_.name" & @CRLF & _
"user._name" & @CRLF & _
"user__name" & @CRLF & _
"user..name" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")