$re = '`^(?:[a-zA-Z0-9]+[._]?[a-zA-Z0-9]+)+$`m';
$str = 'username
user_name
user.name
user.name_123
username$$$
_username
username_
user_.name
user._name
user__name
user..name
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);