// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[a-zA-Z0-9]+[._]?[a-zA-Z0-9]+)+$").unwrap();
let string = "username
user_name
user.name
user.name_123
username$$$
_username
username_
user_.name
user._name
user__name
user..name
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}