import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-zA-Z0-9]+[._]?[a-zA-Z0-9]+)+$";
final String string = "username\n"
+ "user_name\n"
+ "user.name\n"
+ "user.name_123\n"
+ "username$$$\n"
+ "_username\n"
+ "username_\n"
+ "user_.name\n"
+ "user._name\n"
+ "user__name\n"
+ "user..name\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}