using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[a-zA-Z0-9]+[._]?[a-zA-Z0-9]+)+$";
string input = @"username
user_name
user.name
user.name_123
username$$$
_username
username_
user_.name
user._name
user__name
user..name
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}