using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((((?<QT_days>\d+)d)?(?<QT_hours>\d+)h)?(?<QT_minutes>\d+)m)?(?<QT_seconds>\d+)s";
string input = @"1d2h3m4s
4h55m6s
12m34s
21s";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}