import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((((?<QT_days>\\d+)d)?(?<QT_hours>\\d+)h)?(?<QT_minutes>\\d+)m)?(?<QT_seconds>\\d+)s";
final String string = "1d2h3m4s\n"
+ "4h55m6s\n"
+ "12m34s\n"
+ "21s";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}