const regex = /((((?<QT_days>\d+)d)?(?<QT_hours>\d+)h)?(?<QT_minutes>\d+)m)?(?<QT_seconds>\d+)s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((((?<QT_days>\\d+)d)?(?<QT_hours>\\d+)h)?(?<QT_minutes>\\d+)m)?(?<QT_seconds>\\d+)s', 'g')
const str = `1d2h3m4s
4h55m6s
12m34s
21s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}