$re = '/((((?<QT_days>\d+)d)?(?<QT_hours>\d+)h)?(?<QT_minutes>\d+)m)?(?<QT_seconds>\d+)s/';
$str = '1d2h3m4s
4h55m6s
12m34s
21s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);