re = /((((?<QT_days>\d+)d)?(?<QT_hours>\d+)h)?(?<QT_minutes>\d+)m)?(?<QT_seconds>\d+)s/
str = '1d2h3m4s
4h55m6s
12m34s
21s'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end