package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<name>\b[\w-]+\b)=(?<delimiter>["'])(?<value>.*?)(?&delimiter)`)
var str = `IP-Address="192.168.0.0" Servername="UA Local Discovery Server" Rechnername="WG-DE-D11001DS" Comment="Lokaler OPC-UA Server" Type="SimaticNET.S7" Company="Coperion" IntValue='45'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}