$re = '/(?<name>\b[\w-]+\b)=(?<delimiter>["\'])(?<value>.*?)(?&delimiter)/m';
$str = 'IP-Address="192.168.0.0" Servername="UA Local Discovery Server" Rechnername="WG-DE-D11001DS" Comment="Lokaler OPC-UA Server" Type="SimaticNET.S7" Company="Coperion" IntValue=\'45\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);