// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?<name>\b[\w-]+\b)=(?<delimiter>["'])(?<value>.*?)(?&delimiter)"#).unwrap();
let string = "IP-Address=\"192.168.0.0\" Servername=\"UA Local Discovery Server\" Rechnername=\"WG-DE-D11001DS\" Comment=\"Lokaler OPC-UA Server\" Type=\"SimaticNET.S7\" Company=\"Coperion\" IntValue='45'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}