use strict;
my $str = 'IP-Address="192.168.0.0" Servername="UA Local Discovery Server" Rechnername="WG-DE-D11001DS" Comment="Lokaler OPC-UA Server" Type="SimaticNET.S7" Company="Coperion" IntValue=\'45\'';
my $regex = qr/(?<name>\b[\w-]+\b)=(?<delimiter>["'])(?<value>.*?)(?&delimiter)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}