const regex = /^(Entre\ssemana|El\sfin\sde\ssemana)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\sse\sacuesta\sa\slas\s([0-9]{2}\:[0-9]{2}\s)(am|pm)\sy\sse\slevanta\sa\slas\s([0-9]{2}\:[0-9]{2}\s)(am|pm).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(Entre\\ssemana|El\\sfin\\sde\\ssemana)\\s([A-Z][a-z]+?)\\s([A-Z][a-z]+?)\\s([A-Z][a-z]+?)\\s([A-Z][a-z]+?)\\sse\\sacuesta\\sa\\slas\\s([0-9]{2}\\:[0-9]{2}\\s)(am|pm)\\sy\\sse\\slevanta\\sa\\slas\\s([0-9]{2}\\:[0-9]{2}\\s)(am|pm).*$', 'gm')
const str = `Entre semana Juan Miguel Rangel Moncada se acuesta a las 8 pm y se levanta a las 08 am.
Entre semana Jorge Enrique Canon Pinzon se acuesta a las 9 pm y se levanta a las 3 am.
El fin de semana Maria Lucia Espitia Lovera se acuesta a las 7 pm y se levanta a las 12 pm.
El fin de semana Yesid Alexander Munoz Lozano se acuesta a las 10 pm y se levanta a las 5 am.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}