import re
regex = re.compile(r"^(Entre\ssemana|El\sfin\sde\ssemana)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\sse\sacuesta\sa\slas\s([0-9]{2}\:[0-9]{2}\s)(am|pm)\sy\sse\slevanta\sa\slas\s([0-9]{2}\:[0-9]{2}\s)(am|pm).*$", flags=re.MULTILINE)
test_str = ("Entre semana Juan Miguel Rangel Moncada se acuesta a las 8 pm y se levanta a las 08 am.\n"
"Entre semana Jorge Enrique Canon Pinzon se acuesta a las 9 pm y se levanta a las 3 am.\n"
"El fin de semana Maria Lucia Espitia Lovera se acuesta a las 7 pm y se levanta a las 12 pm.\n"
"El fin de semana Yesid Alexander Munoz Lozano se acuesta a las 10 pm y se levanta a las 5 am.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")