$re = '/^(Entre\ssemana|El\sfin\sde\ssemana)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\sse\sacuesta\sa\slas\s([0-9]{2}\:[0-9]{2}\s)(am|pm)\sy\sse\slevanta\sa\slas\s([0-9]{2}\:[0-9]{2}\s)(am|pm).*$/m';
$str = 'Entre semana Juan Miguel Rangel Moncada se acuesta a las 8 pm y se levanta a las 08 am.
Entre semana Jorge Enrique Canon Pinzon se acuesta a las 9 pm y se levanta a las 3 am.
El fin de semana Maria Lucia Espitia Lovera se acuesta a las 7 pm y se levanta a las 12 pm.
El fin de semana Yesid Alexander Munoz Lozano se acuesta a las 10 pm y se levanta a las 5 am.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);