#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*,)?\s*(.*?),\s*([A-Z]{2}),?\s*\d{5}$"
Local $sString = "124 MAIN ST, UNIT 2, STEAMBOAT, CO 76543" & @CRLF & _
"124 MAIN ST UNIT 2, STEAMBOAT, CO, 76543" & @CRLF & _
"124 MAIN ST, STEAMBOAT, CO, 76543" & @CRLF & _
"124 MAIN ST, STEAMBOAT, CO 76543" & @CRLF & _
"STEAMBOAT, GO 12345" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")