import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*,)?\\s*(.*?),\\s*([A-Z]{2}),?\\s*\\d{5}$";
final String string = "124 MAIN ST, UNIT 2, STEAMBOAT, CO 76543\n"
+ "124 MAIN ST UNIT 2, STEAMBOAT, CO, 76543\n"
+ "124 MAIN ST, STEAMBOAT, CO, 76543\n"
+ "124 MAIN ST, STEAMBOAT, CO 76543\n"
+ "STEAMBOAT, GO 12345\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}