const regex = new RegExp('^(?:.*,)?\\s*(.*?),\\s*([A-Z]{2}),?\\s*\\d{5}$', 'gm')
const str = `124 MAIN ST, UNIT 2, STEAMBOAT, CO 76543
124 MAIN ST UNIT 2, STEAMBOAT, CO, 76543
124 MAIN ST, STEAMBOAT, CO, 76543
124 MAIN ST, STEAMBOAT, CO 76543
STEAMBOAT, GO 12345
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}