using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.*,)?\s*(.*?),\s*([A-Z]{2}),?\s*\d{5}$";
string input = @"124 MAIN ST, UNIT 2, STEAMBOAT, CO 76543
124 MAIN ST UNIT 2, STEAMBOAT, CO, 76543
124 MAIN ST, STEAMBOAT, CO, 76543
124 MAIN ST, STEAMBOAT, CO 76543
STEAMBOAT, GO 12345
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}