import Foundation
let pattern = #"^(?:.*,)?\s*(.*?),\s*([A-Z]{2}),?\s*\d{5}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
124 MAIN ST, UNIT 2, STEAMBOAT, CO 76543
124 MAIN ST UNIT 2, STEAMBOAT, CO, 76543
124 MAIN ST, STEAMBOAT, CO, 76543
124 MAIN ST, STEAMBOAT, CO 76543
STEAMBOAT, GO 12345
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)