$re = '/^(?:.*,)?\s*(.*?),\s*([A-Z]{2}),?\s*\d{5}$/m';
$str = '124 MAIN ST, UNIT 2, STEAMBOAT, CO 76543
124 MAIN ST UNIT 2, STEAMBOAT, CO, 76543
124 MAIN ST, STEAMBOAT, CO, 76543
124 MAIN ST, STEAMBOAT, CO 76543
STEAMBOAT, GO 12345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);