package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\|-+\|(?:[\r\n]+|$)`)
var str = `^ A ^ B ^ C ^
|-----------|
Ignore this line
| And | Ignore | This |
^ D ^ E ^ F ^ G ^
|---------------|`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}