re = /^\|-+\|(?:[\r\n]+|$)/m
str = '^ A ^ B ^ C ^
|-----------|
Ignore this line
| And | Ignore | This |
^ D ^ E ^ F ^ G ^
|---------------|'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result