import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\|-+\\|(?:[\\r\\n]+|$)";
final String string = "^ A ^ B ^ C ^\n"
+ "|-----------|\n"
+ "Ignore this line\n"
+ "| And | Ignore | This |\n"
+ "^ D ^ E ^ F ^ G ^\n"
+ "|---------------|";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}