import re
regex = re.compile(r"^\|-+\|(?:[\r\n]+|$)", flags=re.MULTILINE)
test_str = ("^ A ^ B ^ C ^\n"
"|-----------|\n"
"Ignore this line\n"
"| And | Ignore | This |\n"
"^ D ^ E ^ F ^ G ^\n"
"|---------------|")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)