import Foundation
let pattern = #"^\|-+\|(?:[\r\n]+|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
^ A ^ B ^ C ^
|-----------|
Ignore this line
| And | Ignore | This |
^ D ^ E ^ F ^ G ^
|---------------|
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)