#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miuU)^(.*)(\(([^\)]*)%(\s)*\)?)?$"
Local $sString = "Produitun (19 %)" & @CRLF & _
"produit 2 ( 20%)" & @CRLF & _
"produit numéro 3 (5% )" & @CRLF & _
"produitsansprct" & @CRLF & _
"produit Quatre (2.1%)" & @CRLF & _
"autre produit sans prct" & @CRLF & _
"produit 5 (0.1%)" & @CRLF & _
"produit 6 (mélange produit4 (5%) produit 2 (7%))" & @CRLF & _
"produit 7 (15,4%)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")