package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?miU)^(.*)(\(([^\)]*)%(\s)*\)?)?$`)
var str = `Produitun (19 %)
produit 2 ( 20%)
produit numéro 3 (5% )
produitsansprct
produit Quatre (2.1%)
autre produit sans prct
produit 5 (0.1%)
produit 6 (mélange produit4 (5%) produit 2 (7%))
produit 7 (15,4%)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}