using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)(\(([^\)]*)%(\s)*\)?)?$";
string input = @"Produitun (19 %)
produit 2 ( 20%)
produit numéro 3 (5% )
produitsansprct
produit Quatre (2.1%)
autre produit sans prct
produit 5 (0.1%)
produit 6 (mélange produit4 (5%) produit 2 (7%))
produit 7 (15,4%)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}