re = /^(.*)(\(([^\)]*)%(\s)*\)?)?$/mi
str = 'Produitun (19 %)
produit 2 ( 20%)
produit numéro 3 (5% )
produitsansprct
produit Quatre (2.1%)
autre produit sans prct
produit 5 (0.1%)
produit 6 (mélange produit4 (5%) produit 2 (7%))
produit 7 (15,4%)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end