use strict;
my $str = 'Produitun (19 %)
produit 2 ( 20%)
produit numéro 3 (5% )
produitsansprct
produit Quatre (2.1%)
autre produit sans prct
produit 5 (0.1%)
produit 6 (mélange produit4 (5%) produit 2 (7%))
produit 7 (15,4%)';
my $regex = qr/^(.*)(\(([^\)]*)%(\s)*\)?)?$/miup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}