#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a\b[^>]*>(?!<\/a>)<a\b"
Local $sString = "<a href="#1">qwerty</a> - should not match" & @CRLF & _
"<a href="#2">qwe</a><a href="#3">rty</a> - should not match" & @CRLF & _
"<a href="#4"><a href="#5">qwerty</a></a> - should match" & @CRLF & _
"<a href="#6"><span><a href="#7">qwerty</a></span></a> - should match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")