import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\b[^>]*>(?!<\\/a>)<a\\b";
final String string = "<a href=\"#1\">qwerty</a> - should not match\n"
+ "<a href=\"#2\">qwe</a><a href=\"#3\">rty</a> - should not match\n"
+ "<a href=\"#4\"><a href=\"#5\">qwerty</a></a> - should match\n"
+ "<a href=\"#6\"><span><a href=\"#7\">qwerty</a></span></a> - should match";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}