import Foundation
let pattern = #"<a\b[^>]*>(?!<\/a>)<a\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<a href="#1">qwerty</a> - should not match
<a href="#2">qwe</a><a href="#3">rty</a> - should not match
<a href="#4"><a href="#5">qwerty</a></a> - should match
<a href="#6"><span><a href="#7">qwerty</a></span></a> - should match
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)