use strict;
my $str = '<a href="#1">qwerty</a> - should not match
<a href="#2">qwe</a><a href="#3">rty</a> - should not match
<a href="#4"><a href="#5">qwerty</a></a> - should match
<a href="#6"><span><a href="#7">qwerty</a></span></a> - should match';
my $regex = qr/<a\b[^>]*>(?!<\/a>)<a\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}