# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a\b[^>]*>(?!<\/a>)<a\b"
test_str = ("<a href=\"#1\">qwerty</a> - should not match\n"
"<a href=\"#2\">qwe</a><a href=\"#3\">rty</a> - should not match\n"
"<a href=\"#4\"><a href=\"#5\">qwerty</a></a> - should match\n"
"<a href=\"#6\"><span><a href=\"#7\">qwerty</a></span></a> - should match")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.