$re = '/<a\b[^>]*>(?!<\/a>)<a\b/m';
$str = '<a href="#1">qwerty</a> - should not match
<a href="#2">qwe</a><a href="#3">rty</a> - should not match
<a href="#4"><a href="#5">qwerty</a></a> - should match
<a href="#6"><span><a href="#7">qwerty</a></span></a> - should match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);