#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\*\*([^~*]*?~~(?!~))(?:(?1){2})*[^~*]*?\*\*"
Local $sString = "MATCH THESE:" & @CRLF & _
"** basic ~~ case **" & @CRLF & _
"**~~**" & @CRLF & _
"** intermediate ~~ ~~ ~~ **" & @CRLF & _
"** this ~~ is ~~ more~~ ~~complex ~~ **" & @CRLF & _
"" & @CRLF & _
"BUT NOT THESE:" & @CRLF & _
"** three ~~~ tildes **" & @CRLF & _
"** even ~~ number ~~ **" & @CRLF & _
"**some** **stuff~~more**" & @CRLF & _
"**no~~~~~~**" & @CRLF & _
"** ~~~~ ~~~~~~ **"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")