using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\*\*([^~*]*?~~(?!~))(?:(?1){2})*[^~*]*?\*\*";
string input = @"MATCH THESE:
** basic ~~ case **
**~~**
** intermediate ~~ ~~ ~~ **
** this ~~ is ~~ more~~ ~~complex ~~ **
BUT NOT THESE:
** three ~~~ tildes **
** even ~~ number ~~ **
**some** **stuff~~more**
**no~~~~~~**
** ~~~~ ~~~~~~ **";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}