$re = '`^\*\*([^~*]*?~~(?!~))(?:(?1){2})*[^~*]*?\*\*`m';
$str = 'MATCH THESE:
** basic ~~ case **
**~~**
** intermediate ~~ ~~ ~~ **
** this ~~ is ~~ more~~ ~~complex ~~ **
BUT NOT THESE:
** three ~~~ tildes **
** even ~~ number ~~ **
**some** **stuff~~more**
**no~~~~~~**
** ~~~~ ~~~~~~ **';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);