const regex = new RegExp('^\\*\\*([^~*]*?~~(?!~))(?:(?1){2})*[^~*]*?\\*\\*', 'gm')
const str = `MATCH THESE:
** basic ~~ case **
**~~**
** intermediate ~~ ~~ ~~ **
** this ~~ is ~~ more~~ ~~complex ~~ **
BUT NOT THESE:
** three ~~~ tildes **
** even ~~ number ~~ **
**some** **stuff~~more**
**no~~~~~~**
** ~~~~ ~~~~~~ **`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}