re = /^\*\*([^~*]*?~~(?!~))(?:(?1){2})*[^~*]*?\*\*/m
str = 'MATCH THESE:
** basic ~~ case **
**~~**
** intermediate ~~ ~~ ~~ **
** this ~~ is ~~ more~~ ~~complex ~~ **
BUT NOT THESE:
** three ~~~ tildes **
** even ~~ number ~~ **
**some** **stuff~~more**
**no~~~~~~**
** ~~~~ ~~~~~~ **'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end