// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"
(*SKIP)(*FAIL)|[^&\r\n]+(?:&(?!#xA;)[^&\r\n]*)*").unwrap();
let string = "The client requires photos of a radioactive world
Reach the target planet.
The client requires photos.

Reach the target planet.
The client requires photos of a desert world
Reach the target planet.
The client requires photos of an airless world. Reach the target planet.
The client requires photos of a strange world

Reach the target planet
Make a quick scan.
The disturbed region must be accessed by <SPECIAL>Portal<>
Speak to the inhabitants of the Space Anomaly to learn more\" to \"&;A&;&;&;
A";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}