import Foundation
let pattern = ##"
(*SKIP)(*FAIL)|[^&\r\n]+(?:&(?!#xA;)[^&\r\n]*)*"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
The client requires photos of a radioactive world
Reach the target planet.
The client requires photos.

Reach the target planet.
The client requires photos of a desert world
Reach the target planet.
The client requires photos of an airless world. Reach the target planet.
The client requires photos of a strange world

Reach the target planet
Make a quick scan.
The disturbed region must be accessed by <SPECIAL>Portal<>
Speak to the inhabitants of the Space Anomaly to learn more" to "&;A&;&;&;
A
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)