using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https:\/\/www\.test\.com\/items\/)[0-9]+";
string input = @"https://www.test.com/items/1.html
https://www.test.com/items/1123.html
https://www.test.com/items/234.html
https://www.bar.com/items/234.html
https://www.test.com/items.html
https://www.bar.com/items/234.html
https://www.test.com/items.html";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}