// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https:\/\/www\.test\.com\/items\/)[0-9]+").unwrap();
let string = "https://www.test.com/items/1.html
https://www.test.com/items/1123.html
https://www.test.com/items/234.html
https://www.bar.com/items/234.html
https://www.test.com/items.html
https://www.bar.com/items/234.html
https://www.test.com/items.html";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}