package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https:\/\/www\.test\.com\/items\/)[0-9]+`)
var str = `https://www.test.com/items/1.html
https://www.test.com/items/1123.html
https://www.test.com/items/234.html
https://www.bar.com/items/234.html
https://www.test.com/items.html
https://www.bar.com/items/234.html
https://www.test.com/items.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}