import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https:\\/\\/www\\.test\\.com\\/items\\/)[0-9]+";
final String string = "https://www.test.com/items/1.html\n"
+ "https://www.test.com/items/1123.html\n"
+ "https://www.test.com/items/234.html\n\n"
+ "https://www.bar.com/items/234.html\n"
+ "https://www.test.com/items.html\n\n"
+ "https://www.bar.com/items/234.html\n"
+ "https://www.test.com/items.html";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}